php7.1-imagick für SLES kompilieren

Um php7.1-imagick zu kompieren müssen sowohl das php7-devel Paket (für PHP7.1) als auch Imagick-devel installiert sein.

Wichtig: letzters in der aktuellesten Version 6 (nicht 7)!

Danach wird das Paket 

zypper install pecl gcc
pecl install imagick

kompiliert.

Das Kompilat befindet sich in:

/usr/lib64/php7/extensions/imagick.so

Das Modul aktivieren:

echo "extension=imagick.so" > /etc/php7/conf.d/imagick.ini
systemctl reload httpd